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What is it?

A generic solution to handle localization of any text and audio in any number 
of languages.

+ Scripts for displaying Subtitles, Character Portraits and playing Voiceover 
audio.
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What’s in the Package?

LocalizationDBLoader: Knows all the LocalizationDBs (all the available 
languages) for the current level and serves you the one that holds all the 
items in the currently selected language. No singleton, so you have to 
reference it to use it - I use this for main-menu/pause-menu text (or in other 
words: for reusable stuff).

LocCtrl: Same as above, but comes as a singleton. I use this for all the 
dialog in a level. I made the name short so the code will be easier to read. 
LocCtrl.i.db gives you access to the currently selected LocalizationDB.

SpeakerDB: All the paths to the character portraits (put them into 
Resources/GUI/100percent and Resources/GUI/200percent), their sizes and 
if they should be pre-loaded when the level loads (if a portrait is not pre-
loaded, it will be loaded when it's needed.) - I recommend you have on 
prefab for the entire game that holds all your characters and preload just the 
ones you need in the current level.

LocalizationDB: Holds all the text, who's talking and knows where to find 
the matching AudioClips. I use one LocalizationDB per language per level.
Prefab naming convention: LocDB_001_en where "001" is the number of the 
level and "en" is the 2-letter country-code. If the names of your scenes end 
with the same 001 numbering the LocalizationDB Window will be able to fill 
your LocalizationDBLoader with the correct LocalizationDBs automatically 
(but you can always just drag them in manually as well...)
The language string on each LocalizationDB should be a 2-letter country-
code. LocCtrl will look for this when trying to switch to a specific language!

SubtitleController: Easy way to displays subtitles. LocalizationItems are 
queued and displayed one after the other. AudioClips are played via 
VoiceoverController.

VoiceoverController: Plays AudioClips and automatically stops/continues 
when the game is being paused (monitors Time.timeScale)

OrientationControl: Used to position and scale UnityGUI-elements and to 
load normal and retina images. Can be used to handle device orientation 
changes, but Unity can do that by itself now too.
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Getting Started

If you don’t need PlayMaker or NGUI support, delete the NGUILocalization 
and PlayMakerActions folders! (these rely on external scripts and will cause 
errors when left in the project on their own...)

Check out the scene Localization - it has everything set up for you to 
explore!

Open Window > Localization DB to look at the LocalizationDBs in the scene.

The TestScript on the “STORY TEST” gameObject shows you how to use 
SubtitleController to display messages, how to do skipping and how to 
switch between languages.
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Basic Concepts

A LocalizationItem is one line of text with some additional information (who’s 
talking, AudioClip, time)

A LocalizationDB holds all the LocalizationItems for one language (I use one 
LocalizationDB per level per language)

The LocalizationDBLoader holds references to all the LocalizationDBs for the 
current Level.

LocalizationDBLoader

LocalizationDB LocalizationDB
EN

LocalizationDBItems
English Text

English Text

English Text

English Text

English Text

English Text

English Text

DE
LocalizationDBItems

German Text

German Text

German Text

German Text

German Text

German Text

German Text
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How do you access the text?

It’s simple: The LocalizationDBLoader holds a reference to the 
LocalizationDB for the current language in its db property.

So if you have a reference to your LocalizationDBLoader in ldbLoader you 
can do the following:

LocalizationDBLoader ldbLoader;

ldbLoader.db.Get(0); //this will give you the first 
LocalizationItem in the currently selected LocalizationDB

ldbLoader.db.GetMessage(0); //this will give you just the text of 
the first LocalizationItem in the currently selected 
LocalizationDB

And it’s even simpler if you use LocCtrl instead of LocalizationDBLoader - it’s 
exactly the same, but comes as a singleton, so you don’t need to reference it  
- instead you can just do:

LocCtrl.i.db.Get(0); //this will give you the first 
LocalizationItem in the currently selected LocalizationDB

LocCtrl.i.db.GetMessage(0); //this will give you just the text of 
the first LocalizationItem in the currently selected 
LocalizationDB

How do you select another language?

Several options:

• Call SwitchDB(“en”); on every LocalizationDBLoader and LocCtrl in the 
scene. This will change the current language and write the new language 
into the PlayerPrefs (“lan”). 

• Set PlayerPrefs.SetString(“lan”, “en”); and then call SwitchDB(); on 
every LocalizationDBLoader and LocCtrl in the scene. This will write the 
new language into the PlayerPrefs. Calling SwitchDB without any 
parameters will switch everything to the language set in the PlayerPrefs.

7



• Call NextDB(); on every LocalizationDBLoader and LocCtrl in the scene. 
This will simply switch to the next LocalizationDB (if you have multiple in 
one scene, make sure the languages are in the same order!)

• LocCtrl.i.currentLanguage = “en”; Assigning “en” to the 
currentLanguage property will call SwitchDB(“en”).

Check out TestScript.cs for an example of how to switch through a 
predefined set of languages!
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How do you manage the text?

Open Window > Localization DB

This is where you will manage all your text and voiceover-files.

 Header 

LocCtrl: The currently selected LocalizationDBLoader/LocCtrl and a button 
to switch between all LocalizationDBLoaders in the current scene.

Current: The currently selected LocalizationDB and a button to switch 
between all the LocalizationDBs that are referenced by the currently selected 
LocalizationDBLoader (Button shows the current language)

Empty Audio: Empty all AudioClips - You want to have your AudioClips 
loaded when fine-tuning the durations in the LDB Audio window, but you 
want them empty when you build the game.

Refill Audio: Load all the AudioClips from the given AudioPaths

Imp: Import - Load a CSV file and overwrite the values in the current 
LocalizationDB with the values from the file.

Exp: Export - Save a CSV file from the currently selected LocalizationDB. 
Hold down Shift to use the pipe character (“|”) instead of the comma (“,”).
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S: Save - Calls SetDirty on the current LocalizationDB - you don't need to do 
this unless you want to make super-extra-sure that your changes are 
saved…

RL: Reload the LocalizationDB for 
the default language.

 Content 

id: The id of this LocalizationItem. - 
Click it to copy a line of code to the 
clipboard, like this:

SubtitleController.instance.Display(LocCtrl.i.db.Get(0)); //Actual 
Message text

SpID: SpeakerID - the id of the portrait of the speaker in the SpeakerDB

Message: the text

S: Click this button to load and select the corresponding AudioClip for this 
message - Why aren't all the AudioClips always loaded anyway? Because 
you might be developing a mobile game for devices with very little memory 
and wouldn’t want all the AudioClips in memory at once. All AudioClips that 
are loaded in the DB will be loaded when the level launches, everything else 
will only be loaded when it's needed.

AudioClip: The corresponding AudioClip for this LocalizationItem. Drag and 
Drop an AudioClip into this field and the AudioPath and the time will be 
automatically filled in!

AudioPath: The path where the AudioClip can be found

t: time - how long will this message be shown (excluding 0.5s fade-in and 
0.5s fade-out) - the LDB Audio window is there to let you fine-tune the 
durations if you have multiple messages per AudioClips

10



If you don't have a LocalizationDBLoader and/or a LocalizationDB in the scene it will 
show buttons to create your first LocCtrl or LocalizationDB.

If you have a LocalizationDBLoader but it doesn't contain any LocalizationDBs you'll see 
a button called "Auto-Find and Fill LDBLoader" - This will try to find the matching 
LocalizationDBs for this level. But it will only work if your level name ends with 3 numbers 
(for example "Mission001") and the LocalizationDB-prefabs are inside  a folder called 
"Localization" and are named "LocDB_001_en", etc.
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How do you fine-tune the Audio to the text? LDB Audio 
Window!
Open Window > LDB Audio

Arrange your window like this (Inspector on top for the preview of the 
Audioclip, LDB Audio window in the middle and Localization DB Window on 
the bottom) and save it as a layout so you can switch to it quickly whenever 
you need to! 

This makes it easy to fine-tune the times for each item if multiple items 
belong to one AudioClip!

To work on a specific Item, click the “S” (Select) Button in the Localization 
DB Window. This will select the AudioClip and the LDB Audio Window will 
look through all the messages below the first one to see how many items 
belong to this clip and display their times as well.
Click the preview of the AudioClip to play it and you have a convenient way 
to adjust the time of the items below it.

Par: Parts - how many items belong to this AudioClip? (the item that holds 
the AudioClip plus items below it)

DB: Which LocalizationDB are we looking at + a button to switch between all 
the LocalizationDBs referenced by the current LocalizationDBLoader/LocCtrl

R: Reload

Write to: EN/All: Save your changes to the current LocalizationDB by 
pressing the button that shows the 2-letter country-code of the current 
LocalizationDB, or save it to all the LocalizationDBs in the current 
LocalizationDBLoader/LocCtrl by clicking on the "All" button

The second row shows the lengths of the individual elements. Scrub the 
numbers or enter values manually. If you keep the "Match Length" box 
checked the time of the last item will change automatically to match the 
exact duration of the AudioClip.
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Subtitles and Voiceover
Now let’s put our LocalizationDB setup to good use and display some 
subtitles and play some voiceover!

SubtitleController
Feed it with LocalizationItems and it will do the rest!

It requires a VoiceoverController to be present to play AudioClips and a 
SpeakerDB to display character portraits! and OrientationControl to handle 
loading of retina/non-retina images and positioning of the UnityGUI 
elements.

Add an item to the display queue: 
SubtitleController.instance.Display(LocCtrl.i.db.Get(0));

Empty the queue and display a new message right away: 
SubtitleController.instance.DisplayNow(LocCtrl.i.db.Get(0));

Add multiple items to the display queue at once:
SubtitleController.instance.Display(LocCtrl.i.db.Get(new int[]{0, 
1, 2, 3, 4} ));

Display a non-localized string:
SubtitleController.instance.Display("And here is some text that is 
not in the LocalizationDB", 3f);

Remember that you can simply click on the id of an item in the Localization 
DB Window to copy a full line of code to the clipboard like this:
SubtitleController.instance.Display(LocCtrl.i.db.Get(0)); //The 
connection to your mothership has been lost...

Check out the TestScript to see how I’m handling progression and skipping - 
This is how all the missions in NEW ORBIT are built!

http://blackish-games.com/neworbit/
http://blackish-games.com/neworbit/


Changing the looks

Modify the subtitleSkin prefabs to change the looks of the subtitles!

Resources/GUI/100percent/subtitleSkin - non-retina version
Resources/GUI/200percent/subtitleSkin - retina version

subtitleBar: A Texture2D that will be stretched all across the screen

subtitleText: GUIStyle of the subtitle-text

SpeakerDB

This is where you set up all your character portraits!

SpeakerImg: The currently loaded images. But don’t put your images in 
here. Why? See below.

SpeakerImgPath: Put in the names of your character portrait images relative 
to Resources/GUI/X00percent/ and the images will be loaded in the correct 
size when needed.

SpeakerImgDimensions: The pixel dimensions of the 100percent version 
(Will be scaled up automatically for the 200percent image). This is needed 
because your images might not have their actual dimensions after 
compression, but we still want to display them like they were meant to be 
seen.

AutoLoadOnStart: Which portraits to load when the level starts? I find it 
best to have one SpeakerDB prefab that holds all the information and only 
pre-load the characters that appear in the current scene.

Open Window > Speaker DB to get an overview of all your character 
portraits!
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PlayMaker Support
There are now several PlayMaker Actions included and they all share 
common behaviour:

LocDBLoader: Fill it to use a specific LocalizationDBLoader (or LocCtrl). 
Leave it empty and the action will look for a LocCtrl Singleton in the scene!
Ldb ID: The ID of the entry in the LocalizationDB you want to use.

Get Localized Text: 

Language: Fill this in to get text in a 
specific language or leave it empty to 
use the current language.
Text: Set this to a variable and it will be 
filled with a message from the 
LocalizationDB

GUILayout Button/etc. Localized:

Modified versions of the most important GUI and GUILayout Actions that 
display content directly from a LocalizationDB.

Switch Language:

Switch to a specific language. The language value should correspond to the 
language value set in the LocalizationDB (in the examples I use 2-letter 
country-codes)
If you have multiple LocalizationDBLoaders in the scene, make sure you call 
this on every single one of them!

Next Language: 

Switch to the next language (If you have multiple LocalizationDBLoaders 
make sure they all have the LocalizationDBs in the same order and 
remember to call this on every single one of them!)

Check out the PlayMakerLocalization demo-scene to see it in action!



NGUI Support
Our support for NGUI is very similar to NGUI’s built-in Localization support:

Simply add an NGUILocalization component to every UIWidget (Labels, 
Sprites, etc.) you want to localize!

LocalizationDBLoader: Leave it empty to use the LocCtrl singleton in your 
scene -OR- assign a specific LocalizationDBLoader.

Message ID: The id of the message in the LocalizationDB you want to use. If 
it’s valid and a LocCtrl has been found in the scene (or a 
LocalizationDBLoader was assigned) you’ll see a preview of the text (you can 
even toggle through all available languages!)

If you change the language everything updates automatically!

All NGUILocalization components automatically subscribe to 
OnLanguageChange events (Those are sent by LocCtrl and 
LocalizationDBLoaders whenever you call SwitchDB, NextDB or set the 
language through the currentLanguage property)

Check out the NGUI Localization demo-scene to see it in action!



Frequently Asked Questions

Q: What’s the best size for AudioClips?
A: If you’re loading them at run-time you want them small enough as to not 
cause any hiccups on your weakest target-device. I’ve found that files with a 
maximum size of 250-300kb load without problems on a 2nd Gen iPod 
Touch - my weakest target for NEW ORBIT.

Q: What’s the best length for AudioClips?
A: I’ve found that up to 15 sec (1-5 lines of text) works best. (Things to 
consider: skipping, switching languages)

Q: When switching languages, the language of the subtitles doesn’t 
change right away - why?
A: Only items that are added to the Subtitle-Queue after the language was 
changed will be in the new language.

Q: Can I use SubtitleController without a LocalizationDB?
A: Yes! Just do SubtitleController.instance.Display(“Some text”, 2f);

Q: What’s the suggested Workflow to use Localization with Google 
Spreadsheets?
A: Use the “Exp” Button to save a CSV file, add it to Google Drive, modify, 
File > Download as > CSV, use the “Imp” Button to import it back into Unity!
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